在Vestacp上安装Laravel


https://forum.vestacp.com/viewtopic.php?t=16237

check the templates in /usr/local/vesta/data/templates/web/apache2, copy the default.tpl and default.stpl to (for example) laravel.tpl and laravel.stpl and modify the docroot (add public). Then you can choose the new template and laravel should run without any troubles.

If you are trying to deploy the latest Laravel (5.6) you probably need to upgrade your PHP

Laravel 5.6 Server Requirements:

PHP >= 7.1.3
OpenSSL PHP Extension
PDO PHP Extension
Mbstring PHP Extension
Tokenizer PHP Extension
XML PHP Extension
Ctype PHP Extension
JSON PHP Extension